[Libre-soc-dev] LibreSOC Implementation on arty7 fpga dev boards.

lkcl luke.leighton at gmail.com
Fri Oct 8 18:13:52 BST 2021

On Fri, Oct 8, 2021 at 1:00 PM varun mohan <varunmadhavam at gmail.com> wrote:
> OK. So tried as you suggested, but still the same error.
> ERROR: Conflicting init values for signal 1'0 (\test_issuer.ti.jtag.dmi0_datasr_update_core = 1'0 != 1'x).

drat.  this is the same error that Las got, and he was able to fix it
by ensuring that the matching nmigen and yosys versions were used.
please make sure you are using the correct nmigen tag:


> I am now doing all the steps from the beginning again just to ensure that I have not done any damage during my experimentation.

you won't have.  there is no need to redo everything "from the
beginning" - all that will happen is, you will end up at exactly the
same position that you are now.

you are a huge long way along: the main things you have successfully
done are to get the arty actually in, and get symbiflow installed *and
to be used*.

going backwards now will just take 2-3 days, you will get to the exact
same point, and will have wasted 2-3 days.

check first that you *genuinely* have the right version of yosys by
running "yosys --version"

and check that you also have the right version of nmigen
(24jan2021_ls180 tag, which you can get with "git checkout

> Just to confirm once, Litex has to be installed as mentioned in the original litex repo right..!?..specifically by executing the command "./litex_setup.py init install --user" right..!?

probably (i ran it well over 18 months ago).

however after doing so i never updated from that "snapshot" position
because litex is an unstable moving target.

to replicate the exact setup, you will have to go in to each of the
individual repos downloaded by litex (litedram, litex_boards) and
*manually* one-by-one "git checkout {insert checksum} then *re-run*
the "python3 setup.py install" script for *each* individual litex

if they (or we) had used git submodules rather than this type of
arrangement, it would be a lot more convenient, i apologise.

> One more thing, in this link https://libre-soc.org/HDL_workflow/devscripts/ you are installing the python dev repos as root user. Is it necessary...??

you can run the virtualenv version but that then becomes a nuisance in
its own right.  if you are used to dealing with virtualenv however
then that is not a hindrance.


More information about the Libre-soc-dev mailing list