[Libre-soc-dev] LibreSOC Implementation on arty7 fpga dev boards.

varun mohan varunmadhavam at gmail.com
Sat Oct 9 09:50:37 BST 2021

I finally got it to synthesize this time.
The issue was (and I think i missed to convey this point) that i had
installed symbiflow using conda.
It comes with its own version of yosys...!!!.
So to quickly check, i deleted the present conda environment, removed yosys
and symbiflow-yosys-plugin from the dependency list and recreated the env.
Then installed the symbiflow-yosys-plugin manually as in
This time it didn't throw the error and symbiflow was able to move ahead
quite a bit.

But I got this error now..

make: Leaving directory
symbiflow_synth -t arty -v
/opt/src/litex/libresoc-litex/build/arty/gateware/arty.v -d artix7 -p
xc7a35tcsg324-1 -x arty.xdc > /dev/null
symbiflow_pack -e arty.eblif -d xc7a50t_test -s arty.sdc > /dev/null
symbiflow_place -e arty.eblif -d xc7a50t_test -p arty.pcf -n arty.net -P
xc7a35tcsg324-1 -s arty.sdc > /dev/null
Warning: IDELAY_GROUPS parameters are currently being ignored!
/opt/tools/symbiflow/xc7/install/bin/vpr_common: line 94: 93453
Segmentation fault      (core dumped) vpr ${ARCH_DEF} ${EBLIF} --device
${DEVICE_NAME} ${VPR_OPTIONS} --read_rr_graph ${RR_GRAPH}
--read_router_lookahead ${LOOKAHEAD} --read_placement_delay_lookup
make: *** [Makefile:42: arty.place] Error 139
Traceback (most recent call last):
  File "./fpga.py", line 182, in <module>
  File "./fpga.py", line 174, in main
  File "/opt/src/litex/litex/litex/litex/soc/integration/builder.py", line
211, in build
    vns = self.soc.build(build_dir=self.gateware_dir, **kwargs)
  File "/opt/src/litex/litex/litex/litex/soc/integration/soc.py", line
1045, in build
    return self.platform.build(self, *args, **kwargs)
  File "/opt/src/litex/litex/litex/litex/build/xilinx/platform.py", line
50, in build
    return self.toolchain.build(self, *args, **kwargs)
  File "/opt/src/litex/litex/litex/litex/build/xilinx/symbiflow.py", line
252, in build
  File "/opt/src/litex/litex/litex/litex/build/xilinx/symbiflow.py", line
95, in _run_make
    raise OSError("Subprocess failed")
OSError: Subprocess failed

Any clues..!!?


On Fri, Oct 8, 2021 at 10:44 PM lkcl <luke.leighton at gmail.com> wrote:

> On Fri, Oct 8, 2021 at 1:00 PM varun mohan <varunmadhavam at gmail.com>
> wrote:
> >
> > OK. So tried as you suggested, but still the same error.
> >
> > ERROR: Conflicting init values for signal 1'0
> (\test_issuer.ti.jtag.dmi0_datasr_update_core = 1'0 != 1'x).
> drat.  this is the same error that Las got, and he was able to fix it
> by ensuring that the matching nmigen and yosys versions were used.
> please make sure you are using the correct nmigen tag:
> https://git.libre-soc.org/?p=nmigen.git;a=commit;h=060ad2584edccad62e59ddd209f593a4dfc4670a
> > I am now doing all the steps from the beginning again just to ensure
> that I have not done any damage during my experimentation.
> you won't have.  there is no need to redo everything "from the
> beginning" - all that will happen is, you will end up at exactly the
> same position that you are now.
> you are a huge long way along: the main things you have successfully
> done are to get the arty actually in, and get symbiflow installed *and
> to be used*.
> going backwards now will just take 2-3 days, you will get to the exact
> same point, and will have wasted 2-3 days.
> check first that you *genuinely* have the right version of yosys by
> running "yosys --version"
> and check that you also have the right version of nmigen
> (24jan2021_ls180 tag, which you can get with "git checkout
> 60ad2584edccad62e59ddd209f593a4dfc4670a")
> > Just to confirm once, Litex has to be installed as mentioned in the
> original litex repo right..!?..specifically by executing the command
> "./litex_setup.py init install --user" right..!?
> probably (i ran it well over 18 months ago).
> however after doing so i never updated from that "snapshot" position
> because litex is an unstable moving target.
> to replicate the exact setup, you will have to go in to each of the
> individual repos downloaded by litex (litedram, litex_boards) and
> *manually* one-by-one "git checkout {insert checksum} then *re-run*
> the "python3 setup.py install" script for *each* individual litex
> sub-component.
> if they (or we) had used git submodules rather than this type of
> arrangement, it would be a lot more convenient, i apologise.
> > One more thing, in this link
> https://libre-soc.org/HDL_workflow/devscripts/ you are installing the
> python dev repos as root user. Is it necessary...??
> you can run the virtualenv version but that then becomes a nuisance in
> its own right.  if you are used to dealing with virtualenv however
> then that is not a hindrance.
> l.

More information about the Libre-soc-dev mailing list