[Libre-soc-bugs] [Bug 550] binutils support needed for svp64

bugzilla-daemon at libre-soc.org bugzilla-daemon at libre-soc.org
Sun Jan 9 15:37:05 GMT 2022


Jacob Lifshay <programmerjake at gmail.com> changed:

           What    |Removed                     |Added
                 CC|                            |programmerjake at gmail.com

--- Comment #72 from Jacob Lifshay <programmerjake at gmail.com> ---
(In reply to dmitry.selyutin from comment #71)
> A question on matching the names: we have bunch of instructions named like
> "4/6=mtfsfi", "26/6=fmrgow", etc. In good ol' PPC, these have no prefixes, I
> assume SVP64 added them? Should I simply discard everything before '=' sign
> to keep the name as it appears in binutils?

we need to eventually get around to cleaning up our .csv files...those entries
should be moved to a field vhdl_comment or something (they were originally
comments in microwatt's decoder's source) ...allowing the comment field (really
mnemonic) to be just mtfsfi.

dmitry, taking the stuff after an = should be good enough for now.

You are receiving this mail because:
You are on the CC list for the bug.

More information about the libre-soc-bugs mailing list