[Libre-soc-dev] daily kan-ban update 22sep2020

Jacob Lifshay programmerjake at gmail.com
Wed Sep 23 03:28:44 BST 2020

Resolved bug #497, turned out that Luke was using a repo that he
thought was the official upstream for power-instruction-analyzer and
it is different than the repo I was using and had pushed the latest
changes to.

Started working on #499: writing a gdb remote debugging protocol
implementation in nmigen.
Tried to get some examples of gdb's protocol in action, but was
thwarted by qemu. I tried creating a powerpc64le debian chroot and
managed to build a program and run gdbserver -- which promptly ignored
all incoming TCP data, causing my attempts to connect to it to fail.
After trying a few combinations of software versions and stuff, I
decided to create a virtual machine instead. I was again thwarted by
the virtual machine not getting to loading Linux from the debian
install iso, it would just repeatedly hang.

After trying for several hours, I decided that maybe I should figure
out how to tunnel the gdb connection over ssh to the power server that
Raptor is kindly letting us use. I'll try that tomorrow, but it looks
like I'll be out of time before I even wrote one line of code for
#497. :(


More information about the Libre-soc-dev mailing list