[Libre-soc-dev] proposal of change of register name convention in SVP64
ghostmansd at gmail.com
Fri Jul 1 21:09:33 BST 2022
Just so that it won't get missed: Jacob suggested that we adopt *%
convention for vectors. That is, in case you want to refer to vector
%r117, you'll use *%r117. First of all, this syntax recalls of
dereference; second, this combination looks less alien to assembly
code writers, e.g. Intel has such a combination, even though for
entirely different purposes.
I'm choosing this way for now, so that I'm not blocked, and suggest
that we stick to it. Also it fits really well to code.
On Fri, Jul 1, 2022 at 4:16 PM Dmitry Selyutin <ghostmansd at gmail.com> wrote:
> On Fri, Jul 1, 2022 at 4:01 PM Luke Kenneth Casson Leighton
> <lkcl at lkcl.net> wrote:
> > is a hell of a lot of work changing 160+ pages of specification
> > and existing unit tests...
> Well, I'm not sure whether it comforts us a bit, but, at least, this
> change makes insn a bit more straightforward. This was a really
> strange design choice to use the name of the register and its index
> Also, considering we seriously reduce an amount of crap like "hey,
> this argument is optional" and therefore stick to commands being
> non-ambiguous, I'd say this choice keeps us in the same route.
> Best regards,
> Dmitry Selyutin
More information about the Libre-soc-dev