[Libre-soc-dev] Getting an SSH access to the repositories

Luke Kenneth Casson Leighton lkcl at lkcl.net
Mon Jul 12 21:37:46 BST 2021

On 7/12/21, Dmitry Selyutin <dmitry.selyutin at 3mdeb.com> wrote:
> On 7/12/21 9:39 PM, Luke Kenneth Casson Leighton wrote:
>> On 7/12/21, Dmitry Selyutin <dmitry.selyutin at 3mdeb.com> wrote:
>>> On 7/11/21 10:52 PM, Luke Kenneth Casson Leighton wrote:
>>>> if you're happy to, when you have time, ping me on #libre-soc
>>>> on irc.libera.chat, i can go over the simulator etc.
>>>> i've been thinking for a week or so how what would be a
>>>> good way to get started
>>> Thanks for this suggestion, that'd be great! Please, let me know via
>>> direct e-mail when you have some time for this.
>> if you treat IRC as asynchronous and stay logged in (screen with
>> irssi, or use bnc4you or other persistent proxy) we can (eventually)
>> complete a conversation.
> I tried the first thing I found, kvirc. It seems I'm already at
> irc.libera.chat, on #libera channel. It's been a huge time (I guess more
> than a decade) since I used IRC, and I've never used it on Linux. Do you
> have some specific username?

username is entirely your choice, the channel is #libre-soc.

"/join #libre-soc" will do the trick.

>> superb. you shouldn't need coriolis2 or GDHL or iverilog at this point.
> Nice, some parts can be skipped then. Still, I have several issues (I'm
> not sure yet whether I should file these as documentation bugs;
> currently I enumerate these so that I won't forget about them if we need
> to update the docs):

see HDL_workflow: mailing list != editable document store :)

for things that might need action: bugtracker

for info that is repeated and important: wiki

for automated stuff that makes stuff: git repos

> 0. The docs don't mention other scripts which would've been handy, e.g.
> hdl-tools-yosys, or ppc64-gdb-gcc script. I wish I knew about them
> before I installed things manually. :-)

doh :)

> 1. 6.5 Softfloat and sfpy
> This section doesn't mention you need rust. The 6.7 requires it
> explicitly, so I got things working. Also, install-hdl-apt-reqs misses
> rust as well (probably since it's not installed by apt).

it is not strictly necessary, it simply stops some of the IEEE754 FP
unit tests from working, and if you are not running those then you
don't immediately need it.

> 2. 6.7 power_instruction_analyzer (pia)
> $ python3 -m pip install --user target/wheels/*.whl
> power_instruction_analyzer-0.2.0-cp37-cp37m-manylinux_2_24_x86_64.whl is
> not a supported wheel on this platform.
> 3. Docs mention gcc-9. However, the latest available gcc for
> powerpc64-linux-gnu is gcc-8. ppc64-gdb-gcc script makes me think this
> is by no means a coincidence. :-)

yep :)

basically it doesn't matter at this point what you have, 8 9 whatever
as long as you have matching binutils and gdb.

> By now, I'm installing gdb.


> I didn't manage to install
> power-instruction-analyzer (6.7) due to error mentioned above; is it
> essential?

no.  it was removed as a dependency in setup.py for this reason.

stable versions need uploading to pypi, we cannot have people randomly
needing to "upgrade" pip (jacob).

debian/10 was picked deliberately and precisely so that new developers
*do not* have a hell time installing random low level critical

(and also to have repeatable builds)

installing random versions of pip makes for a moving target.

if pia cannot be installed out-of-the-box, it is *pia*'s build process
that needs to be fixed, to work with stable dependencies.

if that means removing the use of pip entirely then that's a good thing.

pip is s*** basically, causes no end of problems.

>> btw what spec system do you have? please say you have 16 GB RAM or
>> greater.
> I wish I had, but this is not a happy reality. :-)

ok :) we can work with this.

> Unfortunately, what
> relates to HDL section 3, I'm a total outsider.

well this is for compiling the HDL, and for the VLSI P&R.  yosys has
bugs where it demanded 22 GB resident RAM. GHDL compilation took 36
GB.  mad.

running the simulator, you could just about get away with 4GB.

> My primary OS is
> ArchLinux with 8 GB RAM; since the recommended environment is Debian, I
> have it on VirtualBox

*screams*.  oracle proprietary code, violating GPL licenses, asking
for trouble, that one.  last time i tried it recommended patching the
linux kernel with some random code, i stopped dead at that.  looked up
online horror stories and never considered trying it ever again.

we did have someone install debootstrap using pacman, there was... one
issue they encountered (and solved). i apologise i cannot recall what,
but it is a route where you would not need a full VM, and would have
the full 8GB available.

> with 2 cores and 2GB RAM allocated. Perhaps I can
> try allocating more RAM.

try "pacman install debootstrap" (pacman -S debootstrap?)

then use that (manually), then under *that* chroot run the devscripts.

chroot in a chroot, i know.

or if that freaks you out do the chroot into the debootstrao manually
and don't run the chroot-devscript.

bit of a pain if trying to set up multiple envs, but hey.

there's always dokkkaah. *shudder*.


More information about the Libre-soc-dev mailing list