[Libre-soc-dev] running microwatt "hello_world.bin" under litex, both microwatt and libre-soc

Luke Kenneth Casson Leighton lkcl at lkcl.net
Fri Sep 4 13:34:18 BST 2020


i thought people might be interested to know that i've worked out a
way (thanks to daveshah from freenode #litex) to run microwatt
"hello_world.bin" under litex.  it also executes the "micropython"
binary (modifications to line 55 left as an exercise to the reader).

both libresoc *and* microwatt can run the same hello_world.bin and
micropython firmware.bin images.

they also have the exact same error when interacting with them
(console read fails) because the litex UART is not a perfect 16550
implementation.  it is *just* enough of an implementation however to
allow for debug (console) log output - just not interactive.

the code above is "stand-alone" and can (as long as litex is
installed) be used without needing to install any of libre-soc's
dependencies (except if wanting to do ./sim --cpu=libresoc).  to run
with the microwatt code (microwatt.v) use "./sim --cpu=microwatt".


crowd-funded eco-conscious hardware: https://www.crowdsupply.com/eoma68

More information about the Libre-soc-dev mailing list