[Libre-soc-bugs] [Bug 433] building pia (power instruction analyser) needs to be documented

bugzilla-daemon at libre-soc.org bugzilla-daemon at libre-soc.org
Fri Jul 24 22:43:16 BST 2020


--- Comment #25 from Luke Kenneth Casson Leighton <lkcl at lkcl.net> ---
(In reply to Jacob Lifshay from comment #24)

> >       Caused by: Only python >= 3.5 is supported, while your using python 2.
> that is the same as https://github.com/PyO3/maturin/issues/333
> as a workaround, build in a python3 virtualenv

right.  i know what they've done.

first: they cannot spell the word "you're" ( the relative pronoun "your" is not
a substitute for the shortening of the phrase "you are")

second: they have assumed that /usr/bin/python is the absolute default link to

if they intended to use python3 they should use "python3" as the command.

the virtualenv workaround most likely works because it adds a shell envvar
which maturin notices and picks up (it is most probably $PYTHON or perhaps

tried $PYTHON... nope.
tried $PYTHON_PATH...  nope

it'll be something like that.

i am not using virtualenv, it would be necessary to do a full total reinstall
of all python packages for libresoc under the same virtualenv, just for a
workaround of this one broken program (maturin).

You are receiving this mail because:
You are on the CC list for the bug.

More information about the libre-soc-bugs mailing list