[libre-riscv-dev] libre-riscv-dev Digest, Vol 23, Issue 16

Samuel Falvo II sam.falvo at gmail.com
Fri Jul 10 21:46:59 BST 2020

On Fri, Jul 10, 2020 at 10:13 AM
<libre-riscv-dev-request at lists.libre-riscv.org> wrote:
> Message: 4
> Date: Fri, 10 Jul 2020 17:10:17 +0100
> From: Luke Kenneth Casson Leighton <lkcl at lkcl.net>
> this is why i sent you a (private) message containing the git
> repositories to clone, and pointed you at the HDL_workflow.  section
> on nmigen:
> mkdir ~/src
> cd !$
> git clone https://github.com/nmigen/nmigen.git
> cd nmigen
> sudo bash
> python3 setup.py develop

I don't know if you noticed, but the path name it was looking in was
underneath the libre-soc directory hierarchy, clearly being installed
contemporaneously with the other parts of the system.  That was one of
the first things I checked for.

I've tried uninstalling nmigen, and re-installing it from scratch, and
again it insisted on installing 0.1.

Just for grins, I tried with "cd nmigen && pip uninstall nmigen && pip
install -e .", and it gave me this result:

ERROR: nmigen-soc 0.0 has requirement nmigen~=0.1.rc1, but you'll have
nmigen 0.3.dev134+g30e2f91 which is incompatible.

Looks to me like there's a transitive dependency mismatch, and that is
what's causing the rollback to 0.1.

> 3. no mention of "virtualenv"

I've *ONLY* ever run nmigen in a virtualenv, and have never once had a
problem with it until now.  Something else must be the problem.  I
know it works, as my continued development of my Kestrel-3 and VDC-II
projects depend on it.

> 4. use of python3 setup.py >>>>DEVELOP<<<< *NOT* python3 setup.py >>INSTALL<<

I did this.

Samuel A. Falvo II

More information about the libre-riscv-dev mailing list